Strona 2 z 2

Re: Błąd wydruków z karty SD

: 29 cze 2015, 22:49
autor: robertm
ArkadiuszB pisze:
unitral pisze:Zacznij od wymiany kabli na krótsze i ekranowane.
Już to przerabiałem...


Nie rozumiem? Połączenie SD do procesora jest bezpośrednio po płytce. Które kable mogą być przyczyną? Bardziej wierzę że to wina repetiera i wersji 0.92


nie napisałeś, że masz na myśli (stole) GATE 1 i dlatego koledzy podrzucają Ci takie, a nie inne sugestie.

Re: Błąd wydruków z karty SD

: 23 gru 2017, 15:33
autor: SlicaR
Podepnę się tutaj z moim problemem.

Poszukuję diagnozy:
Przede wszystkim zaznaczam, że wszystko działało ok, aż za którymś razem:
Włożyłem kartę i zapuściłem wydruk. Osie ładnie się "zahomeowały", stół i dysza rozgrzały.. stół wyjechał do góry i zajął odpowiednią pozycję. I w tym momencie BUM! Wszystko się wyłącza, stół spada i czuję zapach zjaranej elektroniki. Odłączam zasilanie, podłączam znowu i cisza. Trudno. Rozkładam wszystko. Arduino ujarane - po podłączeniu komp go nie widzi. Tylko czerwona diodka się zapala i gaśnie po chwili. Reszta wydaje się w porządku. Dla pewności zamawiam nowe arduino i rampsa. Wymieniam, sprawdzam wszystko, wygląda ok. Wgrywam marlina, wkładam kartę i dzieje się dokładnie to samo. Żadnego komunikatu - nic. Po prostu wszystko się wyłącza. Tyle, że byłem przygotowany i przytrzymałem stół. Wyłączam zasilanie, podłączam znowu i nic. Zero reakcji. Rozbieram elektronikę - wygląda ok. Więc podłączam Arduino do kompa. Wykrywa. Postanowiłem wgrać marlina jeszcze raz i drukarka ożyła. Testuję wszystko - działa. Zapuszczam wydruk jeszcze raz, tym razem nie z karty, a z kompa. Działa. I teraz pytanie: czy karta może spowodować błąd, który spowoduje wywalenie firmware'u i wyłączenie wszystkiego? Czy jednak szukać gdzie indziej? Na razie jedyna różnica jaka przychodzi mi do głowy między tymi wydrukami to to, że jeden jest z karty a drugi nie.
No chyba, że coś z zasilaniem się stało. Tylko co? Mam 2 zasilacze jeden pod stół, a drugi pod resztę. Ale co się takiego uruchamia w momencie rozpoczęcia druku, że nagle miało by spowodować problem? Silnik ekstrudera? Sprawdziłem działanie bez komputera z samego ekranu i działa. Poza tym to się dzieje jeszcze zanim ten silnik cokolwiek zrobi.
Będę wdzięczny za sugestie/pomysły/tropy

Aha: x3dXL, mega, ramps dvr, wyświetlacz graficzny.