Problem z odczytem temperatury

cyberkoko
Posty: 3
Rejestracja: 16 mar 2013, 19:06

Problem z odczytem temperatury

Postautor: cyberkoko » 03 cze 2015, 23:01

Witam, mam taki problem, podczas kalibrowania drukarki, prawdopodobnie przez przypadek doprowadziłem do zwarcia na zasilaniu hotendu i termistora, co spowodowało ustawienie stałej temperatury na termistorze (131,6 stopnia) niezależnie od tego czy jest podłączony termistor pod płytkę czy też nie, próbowałem już:
wciskać reset na płytce - nie pomaga
debugować w prontfacie - nie pomaga
czytałem też że można próbować wgrać nowy firmware ewentualnie że mogę mieć uwaloną całą płytkę (reszta prócz tej temparatury działa, mogę sterować silniczkami, ustawić tempereaturę stołu, nawet hotendu ale bez termistora to raczej strzał w ciemno) ale zanim to zrobię to wolałbym się was spytać i ewentualnie liczyć na jakaś pomoc.

Mix
Posty: 416
Rejestracja: 04 kwie 2014, 22:23

Re: Problem z odczytem temperatury

Postautor: Mix » 04 cze 2015, 1:59

Jesteś pewien że termistor jest sprawny? Podłącz zamiast termistor np. rezystor 100k ohm i zobacz jaką temp. pokaże. Abo jak masz na płytce wejście na termistor stołu to tam podłącz ten termistor i zobacz jakie będą wskazania temp.

Awatar użytkownika
tom4cad
Posty: 524
Rejestracja: 10 mar 2013, 18:23
Lokalizacja: Wrocław
Kontaktowanie:

Re: Problem z odczytem temperatury

Postautor: tom4cad » 04 cze 2015, 8:56

Miałem tak samo, musiałem wymienić atmegę i pomogło.
TDI-CAD Filamenty Wrocław Sklep
http://TDI-CAD.PL

Moje projekty na thingiverse:
http://www.thingiverse.com/tom4cad/designs

zdzban
Posty: 670
Rejestracja: 19 lis 2014, 22:14
Lokalizacja: śląsk-Myszków
Kontaktowanie:

Re: Problem z odczytem temperatury

Postautor: zdzban » 04 cze 2015, 9:43

Jak pokazuje stałą temperaturę to sprawdź termistor podłączając do do omomierza i podgrzewacąc do zobacz na omomierzu czy spada rezynstacja (opór) jeżeli spada to na 90% arduino masz padniete
Pozdrawiam Feniks-3D - części reprap

cyberkoko
Posty: 3
Rejestracja: 16 mar 2013, 19:06

Re: Problem z odczytem temperatury

Postautor: cyberkoko » 05 cze 2015, 13:44

To tak, termistor sprawdziłem, działa. Czyli teraz co mogę jeszcze sprawdzić ? Ewentualnie jeśli zamówię atmege nową to czy będę mógł ją zaprogramować z tej płytki czy jakiś programator będzie mi potrzebny ?

Awatar użytkownika
tom4cad
Posty: 524
Rejestracja: 10 mar 2013, 18:23
Lokalizacja: Wrocław
Kontaktowanie:

Re: Problem z odczytem temperatury

Postautor: tom4cad » 05 cze 2015, 14:01

Jak zamówisz Atmege z wgranym bootloaderem to bedzie mozna wgrac firmware przez usb.
TDI-CAD Filamenty Wrocław Sklep
http://TDI-CAD.PL

Moje projekty na thingiverse:
http://www.thingiverse.com/tom4cad/designs

cyberkoko
Posty: 3
Rejestracja: 16 mar 2013, 19:06

Re: Problem z odczytem temperatury

Postautor: cyberkoko » 10 cze 2015, 17:32

To tak, Atmega wymieniona, wgrany firmware Marlina, dalej wyświetla mi temperaturę głowicy 132 i nic się nie rusza, czy to grzeje czy tez nie. Czy to teraz oznacza uszkodzenie płytki gdzieś i potrzebę wymiany całej płytki ?
Termistor sprawdzałem, jak zamienię z hot bedem to mi podaje temperaturę z głowicy.

zdzban
Posty: 670
Rejestracja: 19 lis 2014, 22:14
Lokalizacja: śląsk-Myszków
Kontaktowanie:

Re: Problem z odczytem temperatury

Postautor: zdzban » 11 cze 2015, 0:30

jak odepniesz przewód z termistorem w Rampsie też pokazuje tobie 132 stopnie?
Pozdrawiam Feniks-3D - części reprap

Awatar użytkownika
tom4cad
Posty: 524
Rejestracja: 10 mar 2013, 18:23
Lokalizacja: Wrocław
Kontaktowanie:

Re: Problem z odczytem temperatury

Postautor: tom4cad » 11 cze 2015, 7:57

W sangu termistory są podpięte bezpośrednio pod piny atmegi. Nie ma nic po drodze. Dlatego jakiekolwiek zwarcie powoduje uszkodzenie atmegi. Musisz się dokładnie przyglądnąć ścieżką od wtyczki do procesora. Tam coś po drodze musi być nie tak. Wyjmij procesor (znajdź na schemacie, które piny atmegi podpięte są pod termistor) i sprawdź czy jest przejście między podstawką pod atmegę a konektorem od termistora.


cyberkoko pisze:To tak, Atmega wymieniona, wgrany firmware Marlina, dalej wyświetla mi temperaturę głowicy 132 i nic się nie rusza, czy to grzeje czy tez nie. Czy to teraz oznacza uszkodzenie płytki gdzieś i potrzebę wymiany całej płytki ?
Termistor sprawdzałem, jak zamienię z hot bedem to mi podaje temperaturę z głowicy.
TDI-CAD Filamenty Wrocław Sklep
http://TDI-CAD.PL

Moje projekty na thingiverse:
http://www.thingiverse.com/tom4cad/designs

zdzban
Posty: 670
Rejestracja: 19 lis 2014, 22:14
Lokalizacja: śląsk-Myszków
Kontaktowanie:

Re: Problem z odczytem temperatury

Postautor: zdzban » 11 cze 2015, 12:02

No tak kolega nie podał dokładnie jaką ma elektronikę myślałem ze Arduino + ramps i tam jest elektrolit C5 i może ona ma przebicie lub rezystor R7 i nie dostaje napiecia.
Ale jak kolega mi inną elektronikę to ja nie pomogę
Pozdrawiam Feniks-3D - części reprap


Wróć do „Sanguinololu”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość