Brak komunikacji - komputer nie wykrywa portu

gargravarr

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: gargravarr » 13 paź 2012, 19:41

Podsumowując temat ożywiłem elektronikę programatorem usbasp z linka. Zmiana JTAGa w programator STK500v2 nie powiodła się pomimo otrzymania od producenta alternatywnego firmwaru. Fuse bity były ustawione na poprawne wartości. Do wgrania bootloadera użyłem avrdude, a dalej poszło zgodnie z opisami z forum. Dzieki za pomoc, wracam do dalszego lutowania i uruchamiania drukarki.

Awatar użytkownika
xbrzydal
Posty: 136
Rejestracja: 07 sie 2012, 22:10

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: xbrzydal » 13 gru 2012, 23:41

Widzę że w watku kłopot jak mój.
Za radą Krzyśka kupiłem programator.

Ale nie bardzo teensylu chce gadać, Próba ustawienia fuse bitów kończy się jak ponizej :(

C:\Users\xBrzydal>C:\Users\xBrzydal\Documents\REPRAP\Elektronika\Bootloades\avrd
ude-5.11-Patch7610-win32\avrdude.exe -C C:\Users\xBrzydal\Documents\REPRAP\Elekt
ronika\Bootloades\avrdude-5.11-Patch7610-win32\avrdude.conf -p usb1287 -P usb -c
usbasp -F -u -U efuse:w:0xF3:m -U hfuse:w:0x99:m -U lfuse:w:0x5E:m

avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
avrdude.exe: AVR device initialized and ready to accept instructions
avrdude.exe: Device signature = 0x000000
avrdude.exe: Yikes! Invalid device signature.
avrdude.exe: Expected signature for AT90USB1287 is 1E 97 82

avrdude.exe done. Thank you

Próba zapisania do fash - również klęska :(

C:\Users\xBrzydal>C:\Users\xBrzydal\Documents\REPRAP\Elektronika\Bootloades\avrd
ude-5.11-Patch7610-win32\avrdude.exe -C C:\Users\xBrzydal\Documents\REPRAP\Elekt
ronika\Bootloades\avrdude-5.11-Patch7610-win32\avrdude.conf -p m128 -P usb -c us
basp -F -U flash:w:C:\Users\xBrzydal\Documents\REPRAP\Elektronika\Bootloades\128
X-usb-boot-1-0-1.hex:a

avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
avrdude.exe: AVR device initialized and ready to accept instructions
avrdude.exe: Device signature = 0x000000
avrdude.exe: Yikes! Invalid device signature.
avrdude.exe: Expected signature for ATMEGA128 is 1E 97 02
avrdude.exe: NOTE: FLASH memory has been specified, an erase cycle will be perfo
rmed
To disable this feature, specify the -D option.

avrdude.exe done. Thank you

No to z -D, ale też nie działa :(

C:\Users\xBrzydal>C:\Users\xBrzydal\Documents\REPRAP\Elektronika\Bootloades\avrd
ude-5.11-Patch7610-win32\avrdude.exe -C C:\Users\xBrzydal\Documents\REPRAP\Elekt
ronika\Bootloades\avrdude-5.11-Patch7610-win32\avrdude.conf -p usb1287 -P usb -c
usbasp -F -U flash:w:C:\Users\xBrzydal\Documents\REPRAP\Elektronika\Bootloades\
128X-usb-boot-1-0-1.hex:a -D

avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
avrdude.exe: AVR device initialized and ready to accept instructions
avrdude.exe: Device signature = 0x000000
avrdude.exe: Yikes! Invalid device signature.
avrdude.exe: Expected signature for AT90USB1287 is 1E 97 82

avrdude.exe done. Thank you.

Może ktoś wie co robię źle ?
Pozdrawiam

--
Brzydal

Awatar użytkownika
Fabrykator.pl
Posty: 8759
Rejestracja: 06 mar 2012, 20:07
Lokalizacja: Darłowo
Kontaktowanie:

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: Fabrykator.pl » 14 gru 2012, 9:19

bezpośrednio z avrdude nie korzystam, tylko z nakładki mkavr, ale z tego co widzę, nie widzi nawet procesora [target doesn't answer. 1]

wulfnor

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: wulfnor » 14 gru 2012, 11:43

Kod: Zaznacz cały

Device signature = 0x000000

To znaczy ze w ogole nie dalo rady odczytac sygnatury, wiec procek nieodpowiada.
Dobrze podlaczyles programator? Jest zasilanie na plytce?

Awatar użytkownika
xbrzydal
Posty: 136
Rejestracja: 07 sie 2012, 22:10

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: xbrzydal » 14 gru 2012, 11:57

"Kabelkologie" sprawdzałem po każdej nieudanej próbie, zgodna z opisem na laminacie i instrukcją programatora.
Zasilanie z programatora ustawione było (odpowiednia zworka wpięta)
Pozdrawiam

--
Brzydal

wulfnor

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: wulfnor » 14 gru 2012, 12:10

no to obawiam sie ze procek wyziona ducha.
Nie zrobiles jakies zwarcia?

Awatar użytkownika
xbrzydal
Posty: 136
Rejestracja: 07 sie 2012, 22:10

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: xbrzydal » 14 gru 2012, 12:25

Nie zdążyłem. To nowa elektronika.
Po podłączeniu do kompa się nie pojawiła na USB, więc wyjąłem zworkę i zresetowałem. Komp zobaczył teensylu, spróbowałem wlać nowego marlina, ale nie chciał gadać z Flipem
Po analizie tego wątku i konsultacji z Krzyśkiem, kupiłem programator ...
Pozdrawiam

--
Brzydal

wulfnor

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: wulfnor » 14 gru 2012, 12:25

no to nie wiem szczerze mowiac :/

Awatar użytkownika
Fabrykator.pl
Posty: 8759
Rejestracja: 06 mar 2012, 20:07
Lokalizacja: Darłowo
Kontaktowanie:

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: Fabrykator.pl » 14 gru 2012, 13:24

tylko, że w PW napisałeś, że

1. Po wpięciu usb nie pojawia się com,
2. Po wypięci zworki i resecie mam LibUSB... czyli OK,
3. Odpalam Flip łączy się z TEENSYLU

Więc przed podłączeniem programatora procesor był sprawny skoro wchodził w tryb programowania :roll: Źle ustawione fusy również mogą uszkodzić procek oraz blokować możliwość programowania

Awatar użytkownika
xbrzydal
Posty: 136
Rejestracja: 07 sie 2012, 22:10

Re: Brak komunikacji - komputer nie wykrywa portu

Postautor: xbrzydal » 14 gru 2012, 13:33

Było jak piszesz. I jak napisałem powyżej: bo Marlina do teensylu wlać się nie dało:
(...)
"Blank check fail at 0x00000"
5. No to bez "Blank Check"
Erase i Program OK
"Verify device fail at 0x00000"
Bez Verify przechodzi, ale dalej nie pojawia się COM.
Pozdrawiam

--
Brzydal


Wróć do „Teensylu”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 2 gości