Teensylu - nie działające silniki

Awatar użytkownika
Tomek75
Posty: 408
Rejestracja: 15 paź 2013, 18:36

Re: Teensylu - nie działające silniki

Postautor: Tomek75 » 06 paź 2014, 19:05

syntetyczny pisze:Chodzi o to, że teensylu to już przestarzała konstrukcja i nie ma sensu marnować czas na jego reanimację.


Tu nie chodzi o reanimacje tu chodzi o ustalenie przyczyny zgonu :bania:

tplewa
Posty: 100
Rejestracja: 22 wrz 2014, 11:09
Lokalizacja: Warszawa

Re: Teensylu - nie działające silniki

Postautor: tplewa » 06 paź 2014, 19:06

W sumie chodzilo o wpiecie LED-ow przez rezystory na piny tam gdzie mierzyles czyli ENABLE, STEP, i DIR... w miare jak bys uruchamial prace silnikow powinny sie odpowiednio zapalac i gasnac... natomiast dioda na STEP powinna migac... lub przy wiekszych czestotliwosciach wysterowania zmieniac jasnosc swiecenia. Mozna i tak ale pomiar miernikiem daje troche dkladniejsze pojecie o stanie ukadu, zwlaszcza ze w swoim ladnie wykorzystales pomiar czestotliwosci :) wiec widac ze tam leci fala prostokatna czyli impulsy STEP...

A co do starych konstrukcji to generalnie AVR-y to starocie ja ich uzywam gdzies chyba od 1999r ;) a juz malo kiedy uzywam bo maja malo atrakcyjna cene nawet w stosunku do XMega Atmela nie mowiac juz o ARM-ach. To co sie pozmienialo to doszly tylko peryferia i zwiekszyla sie pojemnosc FLASH, RAM z biegiem czasu, a rdzen na obecne czasy jest wolny. To byl przelom gdy wchodzily i zastepowaly glownie 8051 w podstawowych wersjach (potem ukazaly sie tez dopalone 8051).
Zreszta nawet uzywanie ARM-ow z przeportowanym softem to takie rozwiazanie bo pakuje sie procesor z algorytmami z ktorymi radzi sobie AVR - wiec procesor sie nudzi. DO puki nie zostana na ARM-ach zaimplementowane ciekawsze algorytmy to to wszystko ma maly sens :) i mozna to nazwac starociami :)
Ostatnio zmieniony 06 paź 2014, 19:11 przez tplewa, łącznie zmieniany 2 razy.

Awatar użytkownika
Tomek75
Posty: 408
Rejestracja: 15 paź 2013, 18:36

Re: Teensylu - nie działające silniki

Postautor: Tomek75 » 06 paź 2014, 19:10

To zbuduje sobie ten układzik zobaczymy co pokaże :git:

Awatar użytkownika
syntetyczny
Posty: 2390
Rejestracja: 08 lut 2013, 23:26
Lokalizacja: Elbląg
Kontaktowanie:

Re: Teensylu - nie działające silniki

Postautor: syntetyczny » 06 paź 2014, 19:34

Tomek75 pisze:Tu nie chodzi o reanimacje tu chodzi o ustalenie przyczyny zgonu :bania:

Zabawę z teensylu zacząłem w styczniu zeszłego roku i po wyeliminowaniu bubli, płytki w postaci KOSa chodzą bezbłędnie już na prawdę długo więc...Przyczynę szukałbym w tym, co pisałem na pierwszej stronie + pare dodatków, które dodałem w KOSie. Schemat jest na githubie więc można sobie luknąć jak kto lubi.
eppure si muove
sklep z akcesoriami RepRap http://www.byq3d.eu

tplewa
Posty: 100
Rejestracja: 22 wrz 2014, 11:09
Lokalizacja: Warszawa

Re: Teensylu - nie działające silniki

Postautor: tplewa » 06 paź 2014, 20:27

Ja mysle ze przyczyna jest znana 1. to to zwarcie, a drugie zapewne przesuniecie wtyczki itp. Po prostu jak sie nieuwaznie grzebie przy wlaczonej elektronice i przepina kabelki to czasem sie tak konczy ;)

O ile mozna sie przyczepiac do bardzo prostych rozwiazan w Teensylu i mozna to by zrobic o wiele lepiej, to te nie dociagniecia nie sa na milon procent powodem uwalania procesora czy stepstickow... Prawde mowiac to mozna w internecie znalezc duzo gorszych rozwiazan ktore dzialaja ;) (akurat nie mowie o sterownikach drukarek, a o projektach na AVR).

Co do KOS to ok ;) troche jest poprawione ale tez nie idealnie, dodany jest dlawik na zasilaniu czesci analogowej (przetwornikow analog/cyfra)... ale co z tego nie ma rozdzialu masy cyfrowej i analogowej. Najlepiej by zrobic aby AVCC i AVDD byly zasilane z osobnych stabilizatorow LDO... do tego rozdzielone masy jak pisalem do masy AGND podpiete mas termistorow. Masy powinny sie laczyc w jednym punkcje przy stabilizatorach. Zabezpieczenie EMI, ESD dla USB powinno byc zrobione jak np. w tym dokumencie http://www.digikey.com/Web%20Export/Sup ... directed=1

I jeszcze tak mozna by dlugo pisac co poprawic ;) Ale nie szukajmy dziury w calym ;) KOS ma na pewno lepsze rozwiazania, ale tez dalekie od idealu... ale nie doszukujmy sie problemow tam gdzie ich nie ma ;)

Awatar użytkownika
syntetyczny
Posty: 2390
Rejestracja: 08 lut 2013, 23:26
Lokalizacja: Elbląg
Kontaktowanie:

Re: Teensylu - nie działające silniki

Postautor: syntetyczny » 06 paź 2014, 20:52

http://www.atmel.com/Images/doc7593.pdf str 316. Można zrobić i płytkę 4ro warstwową z optoizolacją i dopalaczami, tylko po co?
eppure si muove
sklep z akcesoriami RepRap http://www.byq3d.eu

Awatar użytkownika
SWJ
Posty: 2868
Rejestracja: 19 sie 2013, 21:40
Lokalizacja: Poznań

Re: Teensylu - nie działające silniki

Postautor: SWJ » 06 paź 2014, 20:54

... świata nie zbawisz... :bania: :D :git:

można zawsze albo kupić gotowca - taki jaki jest - i cieszyć się maszynką...

albo zrobić wypas płytkę... potem pokatować ją... wyładowania i inne złośliwe metody ... spalić kilka płytek podczas testów ... i potem cieszyć się wypas PCB okupiona kilka "trupami" w szufladzie...

https://www.maritex.com.pl/pl/shop/products/22988/
https://www.maritex.com.pl/pl/shop/prod ... 55/?page=3
// Jarek

=========

... nie tylko drukowanie..

Awatar użytkownika
Tomek75
Posty: 408
Rejestracja: 15 paź 2013, 18:36

Re: Teensylu - nie działające silniki

Postautor: Tomek75 » 06 paź 2014, 21:01

Zatem układ testujący stepstick zrobiłem. Podłączyłem i zbadałem. Przy naciskaniu przełącznika nic się nie dzieje. Silniki ani drgną cisza jak w grobie. Napięcie na potencjometrze sptepstica jest identyczne jak przy podłączeniu do płytki czyli 0,6V i regulacja właściwie nic nie daje. Niestety nie wiem jak ten tester będzie się zachowywać ze sprawnym stepstick wiec na 100 % pewności nie mam że wskazuje iż stepstick jest uszkodzony ale chyba tak jest. :?

tplewa
Posty: 100
Rejestracja: 22 wrz 2014, 11:09
Lokalizacja: Warszawa

Re: Teensylu - nie działające silniki

Postautor: tplewa » 06 paź 2014, 21:02

@syntetyczny

No wlasnie o to mi chodzi - czasami nie ma co przesadzac czy szukac dziury w calym. Chcialem tylko pokazac ze Teensylu mimo ze nie jest to jakis dobry przyklad jak projektowac uklady, ale nie zawiera tez ewidentnych bledow no moze poza brakiem pojemnosci przy rezonatorze... ale to nie wplynie na uwalenie proca tylko brak stabilnej pracy w niektorych wypadkach ;) Natomiast te dwie pojemnosci mozna spokojnie w wersji smd dolutowac dla swietego spokoju ;)

Na nowych bedzie sie krecic ;) mowilem ze nie ma co testowac bo sa uwalone... to co sprawdzales miernikiem dalo niemal 100% pewnosci. Po prostu pech zabilo proca i stepsticki... musialo tam poleciec chyba napiecie z przed przetwornicy stepdown...

Awatar użytkownika
SWJ
Posty: 2868
Rejestracja: 19 sie 2013, 21:40
Lokalizacja: Poznań

Re: Teensylu - nie działające silniki

Postautor: SWJ » 06 paź 2014, 21:10

. . .musialo tam poleciec chyba napiecie z przed przetwornicy stepdown...



jak złącze 3 pinowe przesunięto w kierunku +5V... to na obwody 5V poszło napięcie (minus) 24V a wtedy zgon murowany...
// Jarek

=========

... nie tylko drukowanie..


Wróć do „Teensylu”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość