Teensylu - nie działające silniki

tplewa
Posty: 100
Rejestracja: 22 wrz 2014, 11:09
Lokalizacja: Warszawa

Re: Teensylu - nie działające silniki

Postautor: tplewa » 06 paź 2014, 0:31

nacisniecie i puszczenie - bo z tego co widze w dokumentacji A4988 zmienia sie przy narastajacym zboczu...

mozesz dac NE555 co by nie klikac ;)
http://www.elektroda.pl/rtvforum/files- ... r_8571.jpg i zamiast R3 i LED-a D1 podlaczasz do STEP ;) idac dalej R1 zamieniasz na potencjometr 100K i dajesz za nim rezystor 1K... i masz regulacje predkoci obrotow ;)

No i nie kombinuje do testowania mozna by dac procka i testowac bez podlaczenia silnika z pomiarem przez ADC pradu itd. na wyjsciach silnika ;)

Awatar użytkownika
Fabrykator.pl
Posty: 8759
Rejestracja: 06 mar 2012, 20:07
Lokalizacja: Darłowo
Kontaktowanie:

Re: Teensylu - nie działające silniki

Postautor: Fabrykator.pl » 06 paź 2014, 8:14

Nie wiem czy to miarodajne, ale ja do STP/DIR/ENA podłączam diody LED - mrugają, więc jest ok ;)

tplewa
Posty: 100
Rejestracja: 22 wrz 2014, 11:09
Lokalizacja: Warszawa

Re: Teensylu - nie działające silniki

Postautor: tplewa » 06 paź 2014, 13:42

krzysztof pisze:Nie wiem czy to miarodajne, ale ja do STP/DIR/ENA podłączam diody LED - mrugają, więc jest ok ;)


Tak tez mozna :)

Awatar użytkownika
Tomek75
Posty: 408
Rejestracja: 15 paź 2013, 18:36

Re: Teensylu - nie działające silniki

Postautor: Tomek75 » 06 paź 2014, 14:35

Czy taki układ jest prawidłowy?

Obrazek

I jeszcze jedno pytanie. Na moim stepsticku są dwa rezystory oznaczone jako R20 czyli 200 omów. Mój miernik w obu przypadkach pokazuje mi 0 :? CZy to oznacza że te rezystory są walnięte i to może być przyczyną nieszczęścia :?

Obrazek

Awatar użytkownika
Tomek75
Posty: 408
Rejestracja: 15 paź 2013, 18:36

Re: Teensylu - nie działające silniki

Postautor: Tomek75 » 06 paź 2014, 15:43

To drugie odwołuje to w mili omach jest :bania:

tplewa
Posty: 100
Rejestracja: 22 wrz 2014, 11:09
Lokalizacja: Warszawa

Re: Teensylu - nie działające silniki

Postautor: tplewa » 06 paź 2014, 16:53

nie troche inaczej...
od vdd rezystor 10k do step i od step przelacznik do masy. Do tego reset i sleep polaczone razem tak jak na tamtym schemacie. Akurat jade autobusemmi nie mam jak zerknac w datashet... nie wiem czy reset i sleep maja wewnetrznie podciagniete pullup... wiec nie wiem czy potrzeba je podlaczyc tez przez 10k do +5v czyli do vdd

Awatar użytkownika
Tomek75
Posty: 408
Rejestracja: 15 paź 2013, 18:36

Re: Teensylu - nie działające silniki

Postautor: Tomek75 » 06 paź 2014, 17:24

Wersja poprawiona tester stepstick. Pytanie tylko czy dobrze :D

Obrazek

tplewa
Posty: 100
Rejestracja: 22 wrz 2014, 11:09
Lokalizacja: Warszawa

Re: Teensylu - nie działające silniki

Postautor: tplewa » 06 paź 2014, 18:44

tak teraz jest ok...

Awatar użytkownika
Tomek75
Posty: 408
Rejestracja: 15 paź 2013, 18:36

Re: Teensylu - nie działające silniki

Postautor: Tomek75 » 06 paź 2014, 19:00

A co z diodami bo była jakaś sugestia w tym temacie? Czy np. zamiast silnika można podłączyć do 2A i 2B diodę? Po naciśnięciu przełącznika powinien popłynąć prąd dioda się zapali? :?

Awatar użytkownika
syntetyczny
Posty: 2390
Rejestracja: 08 lut 2013, 23:26
Lokalizacja: Elbląg
Kontaktowanie:

Re: Teensylu - nie działające silniki

Postautor: syntetyczny » 06 paź 2014, 19:01

Chodzi o to, że teensylu to już przestarzała konstrukcja i nie ma sensu marnować czas na jego reanimację.
eppure si muove
sklep z akcesoriami RepRap http://www.byq3d.eu


Wróć do „Teensylu”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 3 gości