Sunbeam 2.0 rev. B - Silnik ekstrudera

Awatar użytkownika
madbarber
Posty: 75
Rejestracja: 21 lis 2012, 23:37
Lokalizacja: Łódź

Sunbeam 2.0 rev. B - Silnik ekstrudera

Postautor: madbarber » 09 lut 2015, 10:50

Wczoraj wieczorem drukarka pracowała normalnie. Dzisiaj gdy przygotowywałem ją do wydruku, po rozgrzaniu hotendu po naciśnięciu extrude, silnik extrudera wykonuje ruchy do przodu i do tyłu. Sytuacja ma miejsce przy obsłudze z panelu jak i kompa.
Wykluczyłem awarię silnika zamieniając wtyczki z osią z. Po zamianie oś z poruszała się jak wyżej, a silnik extrudera poprawnie, to wskazywałoby na driver. Zamieniłem w sofcie piny z drugim extruderem i nie ma poprawy. Po zamianie pinów i wtyczek z osią Z, (czyli oś Z ma piny i wtyczkę tak gdzie był ekstruder, a ekstruder wszytsko tam gdzie Z), oś Z działa porawnie a ekstruder nie. Wyklucza to problem z driverem. Próbowałem podgrywać firmware smoothie ze strony smoothie jak i wulfnora. Bez zmian.
Ekstruder zachowuje się podobnie jak w przypadku pomylenia współrzędnych absolutnych i względnych ale też próbowałem to zmieniać i nic. Nie wiem już jak to ugryźć... .....

Edit:
Dodam jeszcze że ekstruder sprawdzam bez filamentu żeby nie było że się głowica zatkała czy coś...
Pozdrawiam
Kasper

kalus3
Posty: 34
Rejestracja: 05 lis 2013, 21:25

Re: Sunbeam 2.0 rev. B - Silnik ekstrudera

Postautor: kalus3 » 16 lut 2015, 21:26

Mam identyczny problem. Wulfnor, proszę się ustosunkować do tego.

mały_inżynier
Posty: 149
Rejestracja: 26 gru 2012, 23:41

Re: Sunbeam 2.0 rev. B - Silnik ekstrudera

Postautor: mały_inżynier » 16 lut 2015, 22:08

Proponuję napisać do supportu http://hbot3d.com/serwis/

kalus3
Posty: 34
Rejestracja: 05 lis 2013, 21:25

Re: Sunbeam 2.0 rev. B - Silnik ekstrudera

Postautor: kalus3 » 23 lut 2015, 21:33

Witam. U mnie już wszystko działa jak należy, dzięki podpowiedzi serwisu. Zmieniłem w pliku konfiguracyjnym ustawienia prądu (zależne od wersji)

Dla rewizji B:
currentcontrol_module_enable true #
digipotchip ad5206 #

Dla rewizji C:
currentcontrol_module_enable true #
digipotchip mcp4728 #
mcp4726_adress 0xC6 #
mcp4728_adress 0xC0 #


Wróć do „Sunbeam”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 2 gości