Problem z silnikami krokowymi.

Podłączanie silników, elektroniki, krańcówek
Arageus
Posty: 3
Rejestracja: 09 sie 2016, 16:22

Problem z silnikami krokowymi.

Postautor: Arageus » 16 gru 2016, 0:59

Witam wszystkich!

Składam drukarkę prusa i2. Po dłuższym czasie postanowiłem napisać do Was na forum, ponieważ po przewałkowaniu wielu tematów dalej nie mogę poradzić sobie z moim problemem.

Problem: brak jakichkolwiek oznak życia silników krokowych NEMA 17 przy "homowaniu" w pronterface czy innych nakazach poruszenia jakiejkolwiek osi. Z pronterface normalnie jestem stanie sterować temp. stołu i głowicy.

Elektronika: Nema 17, RAPMS 1.4. z wgranym Marlinem (wydaję mi się, że wszystko ustawione jak trzeba)

Częstym problemem są źle podłączone cewki. Za pomocą omomierza znalazłęm dwie pary cewek i podłączyłem następująco. 1a1b - 1 cewka 2a2b druga cewka.

Pozostała elektronika działa bez zarzutu, krańcówki zapalają się przy wciśnięciu, ekran również działa, na potencjometrach stepstików ustawiłem wyliczony prąd na 1.05.

Co do zasilania: używam zwykłego komputerowego 300W. Sprawidziłem i normalnie płytka zasilana jest 12V i 5V tam gdzie trzeba.

Gdy zadałem prontfacowi nakaz np homowania wyskakuje cały czas komunikat :echo:busy:processing. Odpiąlem też jeden silnik i pomierzyłem poszczególne piny na wyjścia na silniki i z masą każdy poszczególny ma około 5v co wiąże się z tym że na wejściu i wyjściu pojedyńczej cewki jest napięcie 0 przy zadanym ruchu drukarki. Nie wiem czy to właściwy sposób mierenia, ale wydaje mi się że między wejściem a wyjściem pinów od jednej cewki powinno iść jakieś napięcie.

Wydaje mi się, że opisałem wszystko co mogłem. Czekam z niecierpliwością na odpowiedź Pozdrawiam.

Arageus
Posty: 3
Rejestracja: 09 sie 2016, 16:22

Re: Problem z silnikami krokowymi.

Postautor: Arageus » 16 gru 2016, 3:43

Dodam jeszcze, że ekran wyświetlacza normalnie działa tylko, gdy płytka podłączona jest usb po lapka, be ztego świeci tylko na niebiesko. Nie wiem czy to ma jakiś wpływ, ale nie zaszkodzi dodać.

Yorg 68
Posty: 101
Rejestracja: 10 kwie 2016, 13:15
Lokalizacja: Myślenice

Re: Problem z silnikami krokowymi.

Postautor: Yorg 68 » 16 gru 2016, 9:23

A tak przypadkiem - nie założyłeś odwrotnie stepsticków?
Nie piszę tego złośliwie - po prostu były takie przypadki. Jeszcze tym bardziej że sterujesz grzałkami - czyli sprzęt żyje.

Edit: Odpowiadam sam sobie - skoro dałeś rady ustawić na stepstickach napięcie 1,05V to nie mogły być odwrotnie włożone.
Drukuję... bo lubię
Jerzy

Arageus
Posty: 3
Rejestracja: 09 sie 2016, 16:22

Re: Problem z silnikami krokowymi.

Postautor: Arageus » 16 gru 2016, 19:11

Niestety stepsticki są podłączone dobrze i nie o to chodzi. Ktoś miałby jeszcze jakiś pomysł?

Awatar użytkownika
arczi
Posty: 5
Rejestracja: 02 gru 2016, 5:47

Re: Problem z silnikami krokowymi.

Postautor: arczi » 31 sty 2017, 1:39

A jak masz zasilanie rampsa podłączone?
Ja złapałem się na tym że podłączyłem tylko na wejściu 5A i nie grzał mi stół, szukałem w marlinie gdy tymczasem wystarczyło podpiąć dodatkowo osobno zasilanie na wejściu 11A i nagle stół ożył :D
Być może u Ciebie sytuacja jest odwrotna?

Awatar użytkownika
animos
Posty: 666
Rejestracja: 05 paź 2013, 10:31

Re: Problem z silnikami krokowymi.

Postautor: animos » 31 sty 2017, 20:37

Nie masz zasilania na silnikach.
Na USB to nie pociągnie - powinno się pojawić już po włączeniu zasilania (bez połączenia komputera).

Prawdopodobnie (to tylko przepuszczenia) dałeś 5V zamiast 12V może?

Lub coś nie styka na zasilaniu - na 1 z 2 styków zasilania (drugi do stołu działa z pronterface).

Generalnie to silniki krokowe powinieneś sprawdzać oscyloskopem podczas ruchu - ale domyślam się, że nie masz.
Masz miernik uniwersalny, więc myślę, że trochę już w tym kierunku zrobiłeś, aby uruchomić drukarkę.
A tak ogólnie to można by nawet poradzić sobie bez miernika (poza ustawieniem prądu sticka) = ewidentnie brak zasilania silników

"12V i 5V tam gdzie trzeba" <-- jesteś tego pewien?
a nie 12V i 12V?
Co jest w instrukcji - nie znam tego modelu.


Wróć do „Elektronika Ogólnie”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość